
iMovie ʼ08 Tutorial Part I-II-III 
 
Introduction 
 
You can use iMovie to import video from a variety of sources and devices so that your  
memories are always at your fingertips. All the clips you have hidden away on your  
digital camera or camcorder, that box full of discs and tapes in your closet, all can be 
edited and stored. With iMovie you can add them to your video library to enjoy anytime. 
With iMovie it’s easy to organize and catalog your video, separate the good from the 
not-so-good, and find just the parts you’re looking for, when you want them. You will be 
able to create quick and simple movies, adding titles over video, scene transitions, 
background music, and voiceovers. iMovie makes it easy to share your movies with 
friends and family.  
 
Over the next several issues of the QuadStar Newsletter we will feature a basic tutorial 
on the use of iMovie ʻ08.  If you have recently purchased a Macintosh that came with 
OSX 10.5 you already have iMovie ʻ08.  If you plan to install iMovie ʻ08 on an older 
Macintosh computer you will need to make sure that your computer meets the following 
system requirements: 
 
System Requirements for iMovie ʻ08 

1. iMovie ʻ08 requires a Mac with an Intel processor, a Power Mac G5 (dual 2.0GHz 
or faster), or an iMac G5 (1.9GHz or faster).  

2. 512MB of RAM; 1GB recommended. High-definition video requires at least 1GB 
of RAM.  

3. Mac OS X v10.4.9 or later.  

4. 3GB of available disk space.  

5. DVD drive required for software installation.  

6. QuickTime 7.2 or later.  

7. Other configurations may be supported. AVCHD video and 24-bit recording have 
additional requirements. Visit iMovie ʼ08 Camcorder Support for more information 
on AVCHD. 

8. Burning DVDs requires an Apple SuperDrive or compatible third-party DVD 
burner.  



 

What You Need to Get Started  
 
As you work on this tutorial over the next few issues of the newsletter you will need a 
source of digital video.  For most people this will be a MiniDV camcorder.  
 
You will need digital video on one of the devices listed in the table below (provided by 
Apple Corporation), or video stored on your computerʼs hard disk or an external hard 
disk connected to your computer with a FireWire cable.  
 

 
 
You should have several gigabytes (GB) of storage space available on your computerʼs 
hard disk or on an external hard disk connected by a FireWire cable. (The amount youʼll 
need depends on the video file format youʼre using. Check the instructions for importing 
video from your recording device for more detail.) If you donʼt have any video available, 
you can still create a slideshow using photos from an iPhoto library.  
 
Gather the equipment and materials that you need to get started prior to the May 
newsletter.  At that time we will import video into iMovie ʻ08 and perform some basic 
assembly editing. 
 
If you are considering the purchase of a MiniDV camcorder, consult with us at 
sales@quadstar.com . We can make recommendations on a MiniDV camcorder that will 
suite your needs and stay within your budget.  There are several features to consider. 
Please donʼt assume that if a camera is MiniDV that it will have the necessary features 
and output capabilities needed to download digital video to your Mac for editing in 
iMovie ʻ08.   
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Specific Camera Requirements 
 
Historically, video has been recorded with analog technology.  Common formats have 
included VHS, SVHS, VHS-C, Hi8 and a few others along the way.  None of these 
formats are compatible with iMovie (or any other computer based video editing tools).  
You would have to convert those analog formats to a digital format (such as QuickTime) 
before they could be used in iMovie. 
 
To edit video on the computer we need to start with video that is recorded in the digital 
format.  We will be focusing on MiniDV for the remainder of these tutorials. One of the 
greatest advantages to editing digital video, is that there is no loss in quality as you 
proceed through the editing process.  Your copies will be exactly the same as the 
original.  As many of us can recall, duplicate copies of VHS tapes suffered significant 
loss of audio and video quality.  Not the case anymore!  Copies of copies of copies of 
Digital Video remain equal to the original. 
 
There are some low cost MiniDV cameras that do not provide for exporting of video to a 
computer (see chart in Part I).  Be certain to purchase a camera that has Firewire 
output.  To be certain that your camera (or one you are considering) is supported by 
iMovie ʼ08 consult the following page of Apple Corporations site: 
http://support.apple.com/kb/HT1014    
 
Note that since new models are introduced every day there may be some lag time from 
when a new model appears on the store shelves to when it is actually listed on the 
Apple site listed above.* 
 
 
iMovie Interface look 
 
Throughout the following pages, we will refer back to the image below that shows the 
major features of the iMovie ʼ08s Main Dialog box. 
 



 
 
 
Opening iMovie 
  
Double-click the iMovie icon in your Applications folder or click the icon in the Dock.  
When you open iMovie for the first time, you see the iMovie window, shown below. 
 

            



As noted earlier, there are many ways to import video into iMovie. In this tutorial we will 
focus on importing digital video from a MiniDV camcorder using the Firewire interface. 
This is the most common way of importing digital video. 
 
Import Video into iMovie  
 
You must first transfer your video to iMovie. Importing video into iMovie does not erase 
it from your recording device. In this step youʼll open iMovie and import video from a 
video recording device, or import a video file youʼve already stored on a hard disk, and 
start building your video library. 
 
Importing Video from FireWire-Equipped Digital Camcorders  
 
If you have a DV or HDV mini-DV camcorder that you can connect to your computer  
using a FireWire cable, youʼll import the video as it plays through on the tape. To import 
video from a camcorder with a FireWire connection: Set the camcorder to VTR mode 
(video tape recorder mode, which some camcorders call “Play” or “VCR” mode) and turn 
it on if it does not turn on automatically.  
 
Connect your camcorder to your Mac using a FireWire cable.  
 
If youʼre importing high definition (HD) video, the 1080i HD Import Setting dialog  
opens. If youʼre not importing 1080i format video, just click OK. If you are importing  
1080i format, or if you will do so in the future, select the size in which you want iMovie  
to import your video. The Large size video is recommended for most ordinary uses  
(including viewing on Apple TV) because it saves hard disk space and may play back  
more smoothly on some computers. However, if your camcorder records in true 1920  
by 1080 HD video, and if you will use this video for broadcasting or exporting to  
Final Cut Pro, select the Full size, which better preserves the original quality of the  
video but uses more disk space.  
 
Note: If youʼre using a DVD camcorder, plugging it into your Mac may cause DVD 
Player to open. If that happens, simply close DVD Player.  
 
Click Import All to import all the clips.  
 
From the Save To pop-up menu, choose a disk where you want to store the imported  
video. You can choose any supported hard disk thatʼs connected to your computer with 
a FireWire cable. It takes about 13 GB to store an hour of standard definition (DV) video  
and 40 GB to store an hour of high definition (HD) video, so make sure you have 
enough space on the disk you choose. The amount of free space on each available disk  
is shown in parentheses next to the diskʼs name in the pop-up menu. Note our 
recommendation of LaCie FireWire HDs recommended for use when storing videos in 
this months featured products.  We recommend 3 times the free space that is needed to 
actually store your original import.  For example, if you import 10 GB of video (that is 



about 45 minutes of video) you should have a minimum 30 GB of free space.  
Remember this is probably temporary storage, since once your project is complete and 
burned to DVD you will remove this data from your hard drive. 
 
Choose how you want to organize the imported video in your Event Library:  
  
To add the imported video to an already existing Event, select “Add to Existing  
Event,” and then choose its name from the pop-up menu.  
  
To create a new Event, type a name for it in the “Create new Event” field (for example,  
“Birthday Party”). If you want to create a new Event for each day on which the video  
was recorded, select “Split days into new Events.”  
 
It can take from several minutes to more than an hour for iMovie to import the video  
and generate thumbnail images of each clip, depending on how many minutes of  
video you have. The progress bars in the Import window indicate which clip is currently  
being imported and how quickly the import is proceeding. 
 
When the video is finished importing, turn off your camcorder and disconnect it from  
your computer. 
 
You now have video recorded on your Mac!  It is that easy.  While we will discuss the 
actual editing process in the third section of this article (June 2008 Newsletter), start 
practicing moving clips of video from your library to the Project window in the top center 
section of the iMovie main window shown above.  Note that dragging multiple clips of 
video will begin to put them in a sequence, which will start to form your edited movie.  
 
 
 
 
 
  
 
*One camera that we recommend is the Canon VIXIA HV30.  This new unit from Canon is very 
affordable at $899 through us at QuadStar (see this months Featured Products in our May 
Newsletter. Here are a few of its important features: 
 

• HD Lens 
• Records both in the DV 4:3 and HD 16:9 formats 
• Full HD Sensor 1920x1080 (this means in a single frame mode you can make quality 

prints up to about 4 x 6 inches! 
• Image stabilization (reduces shaking in your video) 
• Extremely fast auto focus system 
• 2.7” LCD viewfinder 
• Supports 1080i and 1080p playback at  24 or 30 FPS 
• 10x Optical Zoom 
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Organizing Your Video Library and Viewing Your Video 
Video is categorized into Events in your Event Library, where itʼs available for immediate 
viewing, browsing, searching, or modifying. 
 
About iMovie Events 
When you import video into iMovie and give it an Event name, a new Event appears in 
the Event Library, listed by the year in which it occurred. Clicking the disclosure triangle 
for a year in the Event Library displays all the Events in a single year. If the video of a 
single Event spans several days and you elected to separate the days when you 
imported the video, the individual days are listed separately. By choosing the name of 
an already existing Event when youʼre importing new video, you group video from 
multiple sources into one Event. You can also merge multiple Events (or Event days) 
into one, or split a single Event into two. 
 
By merging and splitting events or moving video clips from one Event to another, 
you can organize all your video into meaningful categories and time frames and 
browse through them, similarly to how it is done in iPhoto.  
 
For example, if you imported video from multiple sources that youʼd taken during a 
vacation, all your video from all sources could be grouped together under a single 
Event, for example, “Summer Vacation,” which can easily be found in the year in which 
the vacation occurred. 
 
Selecting an Event in the Event Library displays all the video that Event contains. 
Selecting multiple Events simultaneously displays the video contained in all of the 
selected Events. 
 
To browse multiple Events: 
 
• Hold down the Command key as you click the names of the Events containing 

video you want to browse. 
 

• Select a year in the Event Library to browse all the Events within it. 
 
 
 



            
 
 
 
To merge Events: 
• Select them in the Event Library, and then choose File > Merge Events. 
 
To split an Event into two: 
• Click the video clip you want to make the first clip in the new Event, and then choose 
  File > “Split Event Before Selected Clip.” 
 
To move a video segment (clip) from one Event to another: 
• Drag it to the title of the Event (in the Event Library) where you want it to appear. 
  The Event appears in the Event Library listed under the year in which its most recent 
  clip was recorded. 
  You can also choose to further sort your Event Library by the hard disk where the    
  Video is stored. When your Events are sorted by hard disk, you can browse all the     
  Events on a single disk by selecting the disk name. 
 
To sort the Event Library by hard disk: 
• Click the button with the hard disk icon at the top of the Event Library pane. 
  To learn about more options for organizing your Event Library, see the topic 
  “Reorganizing Events in the Event Library” in iMovie Help. 
 
Viewing Your Source Video 
• Select the name of any Event youʼve created in the Event Library and take a look at   
  the video segments it contains. The video contained in your Events is called source  
  video because it always remains exactly as you imported it and will not be altered by  
  any editing you perform in iMovie. It serves as the source for video that you can use to 
  create movies. 

 
 
 
 
 



Creating an iMovie project: 
1 Choose File > New Project 
2 Type a name for your project 
3 Choose the aspect ratio you want to use for your finished movie from the Aspect Ratio 
   pop-up menu. 
 

Base the aspect ratio you choose on the dimensions of the video and photos that 
youʼll use in your project.    

 
Standard (4:3): Produces a movie for viewing on a standard TV screen or on the 
web. When viewed on an HDTV, there will be black space on the left and right 
sides of the video, known as “pillar box.” 

 
iPhone (3:2): Produces a movie for viewing on the iPhone. 

 
Widescreen (16:9): Produces a movie ideal for viewing on a widescreen monitor 
or high definition television (HDTV). When you view the movie on a standard TV, 
there will be black space above and below the video, known as “letterbox”. 

 
 
Adding clips to your project: 
1 Click a source video clip to select a frame range that you want to include in your 
   project. 
   Four seconds of video are automatically selected. 
2 Click the “Add to Project” button in the middle of the iMovie toolbar to add video to 
   the end of your project, or drag the video selection to where you want it to appear in 
   your project.  
3 Continue selecting video and adding it to your project. 
4 In the project, drag the clips around to rearrange them in any order you want. 
   You can preview your project by playing it one of the following ways: 
 
To play a selected project from the beginning: 
• Click the Play Project button below the Project Library, or press the Backslash (\) key. 
To play a selected project from any point: 
• Press the Space bar or double-click the frame where you want to begin playing. 
To stop playing your project video: 
• Press the Space bar or click anywhere in the iMovie window. 
To play a selected clip or frame range in your project: 
• Press the Slash (/) key. 
 
 
 
 
 



To play a selected project full screen: 
1 Choose where you want to begin playing the project: 
   • To begin playing from wherever the pointer is resting, press Command-G. 
   • To play a project from the beginning, select any clip in the project and click the Play 
      Full Screen button below the Project Library. 
2 Move the pointer and click the filmstrip that appears, and then skim forward and 
   backward through the video. 
3 Press the Escape key to exit full-screen mode. 
 
To adjust a clipʼs duration, one frame at a time: 
1 Move the pointer close to the end of the clip you want to adjust and then do one of 
   the following: 
• Hold down the Command and Option keys. When the orange selection handle 
   appears at the end of the clip, drag the selection handle right or left to extend or 
   reduce the clip duration by one-frame increments. 
• Hold down the Option key while pressing the Left Arrow or Right Arrow key to 
  extend or reduce the clip duration by one-frame increments. 
 
Adding Transitions Between Clips in Your Project 
To add variety and interest to your iMovie project, you can insert transitions that 
smooth the movement between video clips. For example, you can make the images 
from the last frames of one clip fade into the first frames of the following clip, or you 
can create the appearance that one scene is pushing the previous scene off the screen. 
iMovie comes with several handsomely styled transitions that can add flair to your 
project.  
 
 
To add a transition between two clips: 
1 Choose Window > Transitions, or click the Transitions button in the iMovie toolbar. 
   In the Transitions pane, you can preview the available transition styles by letting the 
   pointer rest over each one. 
2 Select the transition you want and drag it between two clips in your iMovie project. 
   A black transition icon appears. 
To preview the transition in your project: 
• Double-click anywhere in the clip just in front of the transition to play through it, 
   or skim through it by dragging the pointer across the transition as quickly or slowly as 
   you want. 
   If you donʼt like the way it looks, you can drag another transition over it to replace it, 
   or delete it and add a different transition at any time. 
To delete a transition: 
• Select the black transition icon, and then press the Delete key. 
   Try out different transitions to see how they look at different points in your project. 
To close the Transitions pane: 
• Click the Transitions button in the iMovie toolbar. 



The length of time between one clip and the next through a transition is called the 
transitionʼs duration. A transition can never have a duration thatʼs greater than half the 
duration of the shorter clip on either side of it. So, for example, if you have a transition 
between one clip thatʼs four seconds long, and another thatʼs six seconds long, the 
transition cannot be more than two seconds long. 
 
By default, all the transitions in your project are set to one half of one second. You can 
change the duration of transitions in the project properties window or by choosing 
Edit > Set Duration. For more details, search for “transition duration” in iMovie Help. 
You can also have iMovie automatically insert the same transition between every clip in 
your project. To learn more about this, search for “automatic transitions” in iMovie Help. 
 
To create a finished movie for viewing on your iPod, iPhone, or Apple TV: 
1 Choose Share > “Share with iTunes.” 
2 Select the size or sizes of movie you want. 

Medium-size movies are best for viewing on an iPod; the large size is best for 
viewing on HDTV. For your iPhone, itʼs best to create movies in both small and 
mobile sizes (iPhone plays either size, depending upon how youʼre connected). 
Some size options may not be available, because the original project media isnʼt 
large enough to render in that size. If your original media isnʼt high definition, 
iMovie wonʼt render the large size movie. 
 

It may take some time to render your project, especially if youʼve chosen to render 
multiple sizes at once. After your movies have been rendered, youʼll find them in your 
iTunes movie library, available for downloading to your iPod or broadcasting to your 
HDTV through Apple TV. 
 
To create a finished movie for use with iWeb, iDVD, GarageBand, and 
other applications: 
1 Choose Share > “Share with Other Applications.” 
2 Select the size or sizes you want for your finished movie, depending on what youʼll 
use it for. 

Some size options may not be available, because the original project media isnʼt 
large enough to render in that size. If your original media isnʼt high definition, 
iMovie wonʼt render the large size movie. 

 
It may take some time to render your project, especially if youʼve chosen to 
render multiple sizes at once. After your movies have been rendered, youʼll find 
them in the Media Browser, available for use in iDVD, iWeb, and GarageBand. 

 
After your project has been rendered for sharing, icons appear next to its name in 
the Project Library, indicating in which sizes itʼs been rendered. 
If you want to edit your project further, iMovie warns you that changing your 
project will make it different from the shared versions in iTunes and the Media 



Browser. The sharing icons disappear until you render the project again. If you do 
render your project again, the previously rendered versions are deleted. 

 
 
These are the basics of creating a simple movie.   We have not discussed items such 
as: 
 

1. Trimming clips 
2. Adding Audio overlay 
3. Various audio and video effects 
4. Inserting single frame images, and rotating a cropping those imagas 
5. Motion and many other special effects 

 
For these more advanced features you can learn more about them on Appleʼs website, 
in the built in help menus or from many of the now available “How to” type books**.  We 
hope that this tutorial will wet your appetite for what you can do with iMovie.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
** How to Books, suggestions: 
iMovie ʼ08 & iDVD: The Missing Manual, David Pogue 2007 
 
iMovie ʼ08 and iDVD for Mac OSX: Visual QuickStart Guide, Jeff Carlson 2007 
 
Credits; 
We wish to acknowledge The Apple Corporation for the use of some of their training and tutorial material in compilation of this 
tutorial. 
 
 
 
 


